Firmware 3.15 Now Mandatory

Non-mandatory Firmware Updates confuse the pants off me. Why are they there when most of the time a month down the line they become mandatory anyway?  This appears to be the case with 3.15, which as of last night you’ll need to download and install if you want to get online, according to reports surfacing overnight.  Nobody at TSA Towers can confirm this as of this morning as those of us awake had installed 3.15 when it arrived a while back, and those of us asleep would go crazy if I woke them for this.

So, Firmware 3.15 is now required, the main focus of which was to allow PSP Minis to run on the PS3.

– ARTICLE CONTINUES BELOW –

Thanks, Bahamut44-4.

– PAGE CONTINUES BELOW –