GTA IV Will Require New Firmware

According to a poster on the official PlayStation forums GTA IV might require a firmware update just to fix the problems early model PS3 owners have been having with the game, due to the custom circuit board. The email reply (from 2K tech support) is as follows:

There is an issue with the launch edition of the PS3 and this game, the game was checked over and passed as 100% compatible with the current version of the PS3, of course the earlier version has custom chips which mean that it is a very different animal from the current PS3 on sale.

– ARTICLE CONTINUES BELOW –

Sony are aware of this difference and are looking into producing a new firmware just for the earlier version of the PS3.

We’ve been OK since the recent patch, but a lot of early adopters are still struggling with freezing and crashing, according to reports.

Source.

– PAGE CONTINUES BELOW –